Trouble installing ET on Linux

Hey guys! I'm having trouble installing ET on my 64bit Linux machine because – I have come to realize after quite a bit of analysis (see below) – the binaries inside the archive are all for 32bit. Can anyone using Linux tell me how they managed to do it? Unfortunately, the instructions on https://wiki.debian.org/Games/WolfensteinEnemyTerritory don't work for me because the package dependencies cannot be satisfied on my Ubuntu system. The same goes for the suggestions on https://askubuntu.com/questions/107230/what-happened-to-the-ia32-libs-package .

I'd really appreciate your help!


[Original post]:
Hey guys! I'm trying to get back in business but ET won't install on my Linux machine. I downloaded the zip file from SplashDamage, unpacked it, executed the `et260b.x86_keygen_V03.run` file in there aaaaand…

$ sudo ./et260b.x86_keygen_V03.run
[ Some dialog opens that asks me what to do about the etkey. I choose any of the options and then… ]
./setup.sh: 192: ./setup.sh: /home/codethief/.setup30185: not found

I'm at a complete loss as to what the issue is – ET always used to work fine on Linux for me. (Also, note that the number at the end of that path changes every time, so I can't simply create that folder.)

Does anyone have an idea what this could be about and how I fix it? I'd greatly appreciate your help! Alternatively, if anyone who also uses Linux could just upload their ET folder somewhere, so that I could simply copy it onto my machine, that'd be GREAT!

[UPDATE]: I extracted the contents of the archive inside the .run file by passing the `--target` option to that file and have now examined the setup.sh file in that archive which I uploaded here: https://pastebin.com/7baY3k4u . The offending line is 192. Turns out the file living at ./setup.data/bin/Linux/amd64 that gets copied to my home folder was compiled for 32 bit systems and therefore cannot be executed on my 64 bit system. The way the command line reacts to this is by pretending that the file doesn't exist, compare https://stackoverflow.com/questions/3949161/no-such-file-or-directory-but-it-exists . Unfortunately, the answer from StackOverflow seems to be outdated. I've updated my question above accordingly but am keeping my original post, so that other people running into the same issue will hopefully find it.
Comments
17
Ur missing dependencies
Thank you, Captain Obvious :)
Parent
u need the ia32-libs
Parent
u tri and u tri but you proof evri time you are mentally not okay
Parent
im on ubuntu 20.04 lts x64

https://www.splashdamage.com/games/wolfenstein-enemy-territory/ official installer
https://help.ubuntu.com/community/Wolfenstein%3A%20Enemy%20Territory dependencies

after installing et, you will get "NO SOUND" problem

https://www.crossfire.nu/journals/156946/wet-linux-sound-fix

you need to install this packages

libsdl1.2-dev/focal,now 1.2.15+dfsg2-5 amd64 [installiert]
libsdl1.2debian/focal,now 1.2.15+dfsg2-5 amd64 [installiert]
libsdl1.2debian/focal,now 1.2.15+dfsg2-5 i386 [installiert]

and than create et.sh

#!/bin/bash

export LD_PRELOAD="/opt/enemy-territory/et-sdl-sound.so"

export ETSDL_SDL_LIB="/usr/lib/i386-linux-gnu/libSDL-1.2.so.0"
export SDL_AUDIODRIVER="alsa"

cd /usr/local/games/enemy-territory

// 60 FPS FIX
Exec=env mesa_glthread=true vblank_mode=0 et



// et.zip
https://drive.google.com/open?id=1aRsuXwvVkQNETOL4V0t5az1sU5hEv59H
Wow, thank you *so* much!
Parent
Thanks for the help! ET works well for most servers, but I still get kicked out PB servers for "game integrity #20006". Did you see this? Tried updating PB files from the one given in etkey.org but then ET won't start anymore, it gets a SIGSEGV when launched.
Parent
So after a strace, I found out that PB was killed while running a stat on /etc/localtime, so I thought it may have something to do with my version of the glibc. Recompiling it (among other things) ended up fixing it!
Parent
What exactly did you have to recompile? Glibc? You wrote "among other things", anything else?
Parent
I downgraded gcc to 9.3.0-r2 and then recompiled glibc, upgraded to 2.32-r6, as well as all the 32 bits shared libraries present on my system. Here is the complete list:


2021-02-16T00:06:28 >>> sys-devel/gcc-9.3.0-r2: 1:27:01
2021-02-16T07:55:57 >>> sys-apps/tcp-wrappers-7.6.28: 26s
2021-02-16T07:55:57 >>> media-libs/libogg-1.3.4: 59s
2021-02-16T07:55:58 >>> media-libs/opus-1.3.1-r1: 1′41″
2021-02-16T07:55:57 >>> dev-libs/libffi-3.3-r2: 3′12″
2021-02-16T07:56:11 >>> app-arch/zstd-1.4.5: 3′07″
2021-02-16T07:58:39 >>> sys-apps/attr-2.4.48-r4: 49s
2021-02-16T07:59:28 >>> sys-libs/zlib-1.2.11-r3: 33s
2021-02-16T08:00:01 >>> dev-libs/expat-2.2.10: 59s
2021-02-16T08:01:00 >>> dev-libs/icu-68.2: 7′05″
2021-02-16T08:08:05 >>> sys-libs/glibc-2.32-r6: 12′02″
2021-02-16T08:20:07 >>> sys-libs/db-5.3.28-r4: 2′56″
2021-02-16T08:23:03 >>> dev-libs/libxml2-2.9.10-r4: 1′29″
2021-02-16T08:24:32 >>> dev-libs/libpcre-8.44: 1′01″
2021-02-16T08:25:33 >>> dev-libs/glib-2.64.5: 2′14″
2021-02-16T08:27:47 >>> sys-libs/ncurses-6.2-r1: 3′55″
2021-02-16T08:31:42 >>> sys-libs/pam-1.5.1: 2′05″
2021-02-16T08:33:47 >>> sys-libs/libcap-2.43: 19s
2021-02-16T08:34:06 >>> sys-apps/util-linux-2.35.2: 3′30″
2021-02-16T08:37:36 >>> sys-libs/gpm-1.20.7-r2: 38s
2021-02-16T08:38:14 >>> x11-libs/libICE-1.0.10: 32s
2021-02-16T08:38:46 >>> x11-libs/libXau-1.0.9-r1: 27s
2021-02-16T08:39:13 >>> x11-libs/libXdmcp-1.1.3: 27s
2021-02-16T08:39:40 >>> media-libs/alsa-lib-1.2.3.2-r1: 1′09″
2021-02-16T08:39:42 >>> x11-libs/libxshmfence-1.3-r2: 1′16″
2021-02-16T08:41:01 >>> x11-base/xcb-proto-1.14.1: 22s
2021-02-16T08:40:58 >>> media-libs/flac-1.3.3-r1: 1′05″
2021-02-16T08:41:23 >>> sys-apps/sandbox-2.20: 1′03″
2021-02-16T08:42:26 >>> media-libs/libvorbis-1.3.7: 1′06″
2021-02-16T08:42:29 >>> net-libs/libasyncns-0.8-r4: 1′12″
2021-02-16T08:42:32 >>> x11-libs/libxcb-1.14: 1′33″
2021-02-16T08:44:05 >>> x11-libs/libSM-1.2.3-r1: 27s
2021-02-16T08:44:32 >>> media-libs/audiofile-0.3.6-r4: 2′04″
2021-02-16T08:44:35 >>> media-libs/libsndfile-1.0.30: 2′17″
2021-02-16T08:44:38 >>> x11-libs/libX11-1.7.0: 2′44″
2021-02-16T08:47:22 >>> x11-libs/libpciaccess-0.16: 30s
2021-02-16T08:47:52 >>> x11-libs/libXext-1.3.4: 25s
2021-02-16T08:48:17 >>> x11-libs/libXfixes-5.0.3-r3: 21s
2021-02-16T08:48:38 >>> x11-libs/libXrender-0.9.10-r2: 23s
2021-02-16T08:49:01 >>> x11-libs/libdrm-2.4.103: 24s
2021-02-16T08:49:25 >>> sys-devel/llvm-11.0.0: 1:43:13
2021-02-16T10:32:38 >>> x11-libs/libXrandr-1.5.2: 25s
2021-02-16T10:33:03 >>> x11-libs/libXi-1.7.10: 32s
2021-02-16T10:33:35 >>> x11-libs/libXdamage-1.1.5: 22s
2021-02-16T10:33:57 >>> x11-libs/libXxf86vm-1.1.4-r2: 26s
2021-02-16T10:34:23 >>> media-libs/libglvnd-1.3.2-r2: 33s
2021-02-16T10:34:56 >>> media-libs/mesa-20.2.6: 11′50″
2021-02-16T10:46:46 >>> x11-libs/libXtst-1.2.3-r2: 23s
2021-02-16T10:47:09 >>> media-libs/glu-9.0.1: 45s
2021-02-16T10:47:54 >>> sys-apps/dbus-1.12.20-r1: 1′24″
2021-02-16T10:49:18 >>> media-sound/pulseaudio-13.0-r1: 2′57″
2021-02-16T10:52:15 >>> media-plugins/alsa-plugins-1.2.2: 36s
2021-02-16T10:52:51 >>> media-libs/libsdl-1.2.15-r9: 1′17″
Parent
thx worked fine for me, same distro
fixed the 60 fps and sound
Parent
COLTTHIEF
Trouble installing ET on Linux
problem spotted, check your commandmap/hide]
Back to top